Getting Started with ZYMKEY 4i


#22

Hi,
thx for your quick answer:

  • no the problem zymkey is NOT locked; it worked well until the problem appeared suddenly;

  • I am afraid I can’t test anything at all: the zkOpen(&ctx) function always fails with the “problem” zymkey and returns -ETIMEDOUT (=-110) … So I can’t work with it.
    -Should I try to execute the setup.sh script again to try to bind the “problem zymkey”? I already tried it many times.
    -This zymkey was first used on a jessie distrib, could it be the origin of the problem?

  • I will try with all my others zymkey, but I am not in the good place right now; I will do it in a week…


#23

Hello,
I have successfully installed the zymkey module and used Luks encryption, everything works just fine as expected. Now, how can I use the zykey key store to keep one or more Private keys that I needed for authentication when connecting to external services? Are there APIs that I can use to insert the keys to key store and retrieve them on demand?

Thanks in advance