Help Using Stretch


#1

hoping to get some help. when following the instructions for stretch

root@pg-209:~# apt-get install curl rpi-update libcurl3
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
rpi-update : Depends: binutils but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@pg-209:~# openssl version
OpenSSL 1.0.1t 3 May 2016
root@pg-209:~# nano /etc/apt/sources.list
root@pg-209:~# apt-mark hold openssl
openssl set on hold.
root@pg-209:~# apt-mark hold curl libcurl3
E: Can’t select installed nor candidate version from package ‘curl’ as it has neither of them
E: Can’t select installed nor candidate version from package ‘libcurl3’ as it has neither of them
E: No packages found


#2

One question comes to mind: had you run through the OpenSSL instructions once already on the same install?

It’s worth mentioning that we will have proper Stretch support very soon (end of March).


#3

I fat fingered jessie. Thanks for letting me know stretch support is coming soon. If I can get a proof of concept going with the couple zymbits I have on hand the march release will be good timing for me.

When I follow the doc I get this error for rpi-update. What should I do here?

root@pg-200:~# apt-get install curl rpi-update libcurl3
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
rpi-update : Depends: binutils but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


#4

so I skipped rpi-update using jessie repo, and reinstalled it with stretch. continued on… got to here (see below), but then it seems it never finishes up on 2nd phase. blue light flashes fast and never stops. I let it sit for a few hours and pulled the power and does the same thing. My build i have a splash screen it boots to that and just sits after the 1st reboot…

Formatting USB mass media on /dev/sda…1+0 records in
1+0 records out
512 bytes copied, 0.00879355 s, 58.2 kB/s
Device /dev/sda already contains a udf signature.
It is strongly recommended to wipe the device with wipefs(8), in order to avoid possible collisions.
mke2fs 1.43.4 (31-Jan-2017)
Making a tarball of original root file system image…tar: Removing leading /' from member names tar: /root/.cache/pcmanfm-socket--0: socket ignored tar: Removing leading/’ from hard link targets
done.
Created symlink /etc/systemd/system/multi-user.target.wants/cfg_SD_crfs.service → /etc/systemd/system/cfg_SD_crfs.service.
Removed /etc/systemd/system/multi-user.target.wants/zkifc.service.
Removed /etc/systemd/system/multi-user.target.wants/zkbootrtc.service.
2,640,738,107 94% 8.58MB/s 0:04:53 (xfr#75557, to-chk=0/106003)
sed: -e expression #1, char 21: unterminated address regex
done.
root file sys conversion phase 1 complete.
Rebooting to installer partition to start phase 2…