Enabling I2C Bus

I am trying to automate some of the installation process. I thought I could change the file /boot/config.txt to uncomment the # in front of dtparam=i2c_arm=on and this would work. However … neither the HSM4 nor the Zymkey “bind” (turn from blinking rapidly to once every three seconds) until I manually open the raspberry pi config from the terminal and enable the I2C bus that way. Does anyone know why this is? And if I can avoid it?

You will also need to tell the kernel to load the i2c-dev module. Edit /etc/modules
and add the line i2c-dev. Reboot and use ls -l /dev/i2c* to verify that the i2c bus now exists.

1 Like