Problem with rtc

Hello
I have a problem with rtc in zymkey 3i and Raspberry 3B+:
Zymkey`s RTC is not getting current time, after I insert battery cell.
With fresh installation of latest Raspbian, latest zymkey software installation, blue light blinking slowly, Raspberry connected to internet, NTP is synchronized. But RTC is not updating. zymkey.client.get_time() – return very low numbers.
I tried sudo timedatectl set-ntp true and reboot several times, tried to wait long period of time – all without success.
What could be the problem? Could I somehow force setting time in RTC?

Little update.
With sudo cat /var/log/syslog | grep zkifc, I see a lot off messages like:
Apr 20 15:57:36 neobox zkifc[798]: NTP not ready
But timedatectl says that System clock synchronized and NTP service is active.

What does timedatectl status say?

Also, are you running Raspbian Buster?

Yes. Latest Raspbian Buster Lite.

timedatectl status

           Local time: Mon 2020-04-20 20:22:28 BST
       Universal time: Mon 2020-04-20 19:22:28 UTC
             RTC time: n/a
            Time zone: Europe/London (BST, +0100)

System clock synchronized: yes
NTP service: active
RTC in local TZ: no

After investigating, it looks like there have been some changes to the timedatectl utility that have affected our software components. We will fix this issue in an upcoming release.

After you have fixed the issue, can we update the devices which was already running production mode? or do we need to re-install the zymkey client?

Yes, once the repo has been updated I’ll post an announcement. Then a simple

sudo apt update
sudo apt upgrade

is all that should be needed.