Buster repo not working on rpi4

On a rpi4 with a zymbit 4, and am getting the following repo errors when running the getting started script
curl -G https://s3.amazonaws.com/zk-sw-repo/install_zk_sw.sh | sudo bash

Note: Had to post image as was getting the following error in the support forum:

Sorry, new users can only put 2 links in a post.

Can someone point me in the right direction?

I just tried a fresh run of the install_zk_sw.sh script and the key worked fine for me. Try and load the key on its own.

curl -L “https://zk-sw-repo.s3.amazonaws.com/apt-zymkey-pubkey.gpg” 2> /dev/null | apt-key add - &>/dev/null

You can see whether you got the key with “sudo apt-key list”? There should be an entry like this:

pub rsa4096 2018-09-28 [SC] [expires: 2020-09-30]
DA70 7A06 7BFE 1CFD 459B 42F3 CAA5 E9C8 755D 21A0
uid [ unknown] scott@zymbit.com

If that works, then the easiest thing would probably be to start over clean. If it doesn’t, let me know and we can figure out why you are not receiving the key.