Zymkey with Ubuntu 22.04 LTS on Raspberry

is there an time plan when the Zymbit installer is available for Ubuntu 22.04 LTS?
I have more then 10 zymbit devices but cant use them because the installer failed with the python aplication.

Thank you in advance and best regards,


@mikeyy - Yes, we are working on this. We should have a solution tested and posted by the end of the week.

oh. sound good. Thank you for your fast response. I would like to test it :slight_smile:

Hello together,

there are any news or updates about the theme?

Thank you and best regards,

@mikeeyy working through it. Most of the pieces are in place. Just running a little late.

I tried to used current Zymbit installer for Ubuntu 22.04. It works fine. You just need to use python-is-python3 installation so that Zymbit script run successfully. In my case first I run " curl -G https://s3.amazonaws.com/zk-sw-repo/install_zk_sw.sh | sudo bash". Then run " curl -G https://s3.amazonaws.com/zk-sw-repo/mk_encr_sd_rfs.sh | sudo bash" to convert sd card to LUKS. I feel encryption is possible and the one I am testing is accurate. @Bob_of_Zymbit kindly correct me if I m wrong. Thank you.

@Yashashree - We supplemented the install script and added a repo for 22.04 over the weekend. The doc site needs to catch up but it should be supported now. I’ll double-check the need to add python-is-python3 as I didn’t think that should’ve been needed.