~/.config/lxsession/LXDE-pi/autostart doesn't work

Hi, I recently bought the Zymkey 4i for my project. A few months ago, I edited the ~/.config/lxsession/LXDE-pi/autostart file to run a Python script on start-up, and it always worked great. But after I installed the necessary software for the Zymkey with curl -G https://s3.amazonaws.com/zk-sw-repo/install_zk_sw.sh | sudo bash and let the system reboot, the autostart stopped working, although the file remained unchanged. I’ve searched the internet, but the only thing I found was to edit ~/.config/lxsession/LXDE-pi/autostart instead of /etc/xdg/lxsession/LXDE/autostart, but that’s not my case. Would you happen to have any tips?

the ~/.config/lxsession/LXDE-pi/autostart file:

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@lxterminal -e python startserver.py

@jan autostart from user pi’s home directory worked for me. I’m using bullseye64. What OS are you running, and what’s in your startserver.py?