Configuration error


The Zymkey4 never seems to go beyond the 5 blinks per second step.

Did configure everything: I2C and zymkey services as described in the docs.

I tried the python examples and it returns an error.

The configuration:
Pi: Model 3B+
OS: Raspberry Buster 2019

It did use to work but after an OS update it stopped working. From there on nothing seems to be able to configure the zymkey, including reinstalling the Pi OS. Also, tried the a second zymkey on a clean OS and still the same problem.

Could you please advice on how to solve the issue.

Thank you.

@alexm - Please take a video of the LED flashing sequence so we can confirm what is going on? Please send to and we can work through there as we may go back and forth a few times.



I moved Zymkey to Pi4 Model B 2018 (Buster OS) and it works (tested on the provided python examples).

I can confirm that it does not work on my Pi3 Model B+ 2017 (Buster OS).

It is quite strange that it used to work on Pi3 and after an OS reinstall it doesn’t. Are Zymkey meant to work on Pi3 Model B+?

It might be a power issue as the device is not going into the configuration phase (always 5 blinks per second).

Best regards,


@alexm The ZYMKEY will work on both the PI4 and the PI3B+. A good power supply is required. We have tested with the latest Buster (12/01) and the PI3B+. Please make sure you have a good supply for you PI3B+, a Canakit or Raspberry PI model, not a phone charger.