Does not enter developer mode - temporary binding

Hello, I have been trying to get my zymkey to bind with my RPi 3B+ running stretch. After I run the install line from the getting started page,

“curl -G | sudo bash”

I get the following error message:

“Installing prerequisites…E: Command line option --allow-releaseinfo-change is not understood in combination with the other options”

Then the install seem to proceed as normal. The Pi reboots, but does not bind, just keeps blinking at the fast, steady, rate link when you just connect it.

I then tried to run the python scripts:

python /usr/local/share/zymkey/examples/
python /usr/local/share/zymkey/examples/

but there does not seem to be an example folder in the /usr/local/share/zymkey dir, only a doc folder. exPic

Any help you could give would be greatly appreciated.

Many thanks in advance.

Hi Cameron,

Stretch on the RPi 3B+ completed fine for me. I think that first error is because that option is supported in Buster, not Stretch. I don’t think it causes any problem. I saw the same error and my installation worked.

Can you confirm which version of Stretch you are using? Can you give me the output of “uname -a”? Two other questions: Is your power supply adequate? The RPI 3B+ needs 2.5 to 3 amps. Do you have any other hardware on your Pi, any HATs or something that might share resources with the Zymkey?


Hi Bob, Thanks. That explains the missing dir. I just disabled the one-wire interface. That seems to have resolved the moving to developer mode issue. I am now stuck in trying to move to phase 2 of Converting an Existing SDcard to LUKS, i.e.,

curl -G | sudo bash

It gets to this part, but when it reboots, nothing seems to change.

root file sys conversion phase 1 complete.
Rebooting to installer partition to start phase 2…

Also, when it reboots the blue LED turns off.

As for the PWR supply:
I am using a 2.5A supply with an Anker powerline USB.

For the OS:
Linux NAIPi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux

For other HW: