Failed installation - Failed to fetch

Hi, I’ve tried installing the libraries on my Zymkey 4i many times, but none of the attempts were successful. I have a product built on the Raspberry Pi 4B, and the last thing was to secure the data. After I got the Zymkey, I followed every single step from the tutorial, and everything seemed to look normal on my 64-bit Raspberry Pi OS Bullseye (Raspbian OS GNU/Linux 11) with Python 3.9.2 as the default Python version, but when I tried importing the zymkey library, I got an ImportError: No module named zymkey. I searched the internet for a solution and found: ImportError: No module named zymkey but with no result because running the installing command twice had no effect, and @alohaJoe solved the problem by installing a clean installation of 64-bit Bullseye. But when I tried a clean installation of 64-bit Bullseye, 32-bit Bullseye, or 64-bit Bookworm with the default Python version of 3.11.2 or 3.9.2, the best I could get was:

E: Failed to fetch 403 Forbidden [IP: ...]
E: The repository ' bookworm InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Installing Zymkey Packages...

This error showed up on my Bullseye and Bookworm versions.
Any ideas?

@Jan We have not added support for bookworm yet. Your error messages indicate you are trying to fetch from a Zymbit bookworm 64-bit repo that does not exist. This would be coming from /etc/apt/sources.list.d/zymbit.list somehow referencing bookworm-aarch64, maybe from a previous attempt?

We support bullseye 64-bit and 32-bit. Please note in the Quickstart, for 32-bit

As of March 2023, Raspberry PI OS 32-bit images install the 64-bit kernel along with the 32-bit root filesystem. This does not allow our installation script to work. In order to properly install on an 32-bit system, edit /boot/config.txt and add the following line to the bottom of the file, then reboot.


any outlook on the supportability of Bookworm ?

Yes, bookworm (64-bit) support has been added. See chart of supported OS’ here: