Trouble when Importing Zymkey: No zymkey module, zkbootrtc fail


#1

Hello,

We are having a problem here at Raspberry Pi running with Zymkey 4, a battery, a led and a cooler. The following error happens all the time:

zkbootrtc.service - Restore System Clock from Zymkey
Loaded: loaded (/etc/systemd/system/zkbootrtc.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Mon 2018-12-03 16:26:20 -02; 23min ago
Process: 308 ExecStart=/sbin/zkbootrtc (code=exited, status=255)
Main PID: 308 (code=exited, status=255)
CPU: 24ms

Dec 03 16:26:20 rasp41 systemd[1]: Starting Restore System Clock from Zymkey…
Dec 03 16:26:20 rasp41 zkbootrtc[308]: ERROR: no zymkeys installed.
Dec 03 16:26:20 rasp41 systemd[1]: zkbootrtc.service: Main process exited, code=exited, status=255/n/a
Dec 03 16:26:20 rasp41 systemd[1]: Failed to start Restore System Clock from Zymkey.
Dec 03 16:26:20 rasp41 systemd[1]: zkbootrtc.service: Unit entered failed state.
Dec 03 16:26:20 rasp41 systemd[1]: zkbootrtc.service: Failed with result ‘exit-code’.

Sometimes the error happens when none of the components are attached to it, but it is less frequent. We already tried to uninstall zymkey and install again, what worked until we put together the other components. Because of this error it is impossible to import zymkey module at python and use any of its functions. Sometimes the module is imported, but then all functions stop working after a while. For some reason, the disk encryption keeps working.

To try to go through the problem, I have put a line on the code which will restart zkbootrtc and zkifc everytime an error happens, which worked for a while, but then it stopped everything and even the disk decryption clashed. It is not a good way to try correcting the problem, but it was the only way I could find. The worst is that sometimes zkbootrtc does not starts even if we restarts it enumerous times. Because of that we cannot use python zymkey and with it, perimeter detect info and other stuff.

Any possible solutions or idea of the problem?


#2

It sounds like Zymkey is not reliably communicating to the host RPI.

Here are some Immediate ideas/questions to help us help you:

  • What RPI type and what OS flavor/version are you using ?
  • Do you have any other hardware devices connected to the GPIO header ?
  • What are the LED and the cooler components you have installed ?
  • Are you using keyboard and monitor to talk to your device, or SSH ? Is there a HDMI monitor plugged in either way ?
  • What power supply are you using ?

If you prefer to have the conversation in private, then please email support@zymbit.com and we will respond there.