Zymbit 4i Cmd processor failure


Having successfully installed and configured the zymbit with my pi after I rebooted it now fails to work.
The LED blinks rapidly continually.

Checking the service status (systemctl status zkifc.service) gives this error message:
Jul 31 13:22:04 systemd[1]: Starting Zymkey Interface Connector…
Jul 31 13:22:04 systemd[1]: Started Zymkey Interface Connector.
Jul 31 13:22:07 zkifc[1041]: Cmd processor failure

Trying to run example code gives:

python /usr/local/share/zymkey/examples/zk_app_utils_test.py

Testing data lock…
Traceback (most recent call last):
File “/usr/local/share/zymkey/examples/zk_app_utils_test.py”, line 6, in
dst = zymkey.client.lock(src)
File “/usr/local/lib/python2.7/dist-packages/zymkey/module.py”, line 226, in lock
raise AssertionError(‘bad return code %d’ % ret)
AssertionError: bad return code -1

I’m using the Zymbit 4i with a RasPi 4 (4G model) with the official POE HAT and extended gpio pins.
Running stock Raspbian 10.4 Linux 5.4.51-v7l+ #1327 SMP Thu Jul 23 11:04:39 BST 2020 armv7l GNU/Linux
Red power LED is illuminated steadily, no voltage warnings in dmesg.

Any clues as to what might be wrong?

Hi Mike,

It sounds like there might be an I2C bus issue. First thing I have to ask is to make sure you enabled the I2C bus via raspi-config or the desktop GUI. Next thing would be a potential conflict of resources with the POE HAT. Can you give me a link to the POE HAT so we can determine what GPIO pins, etc. it uses?



This is the hat:https://www.raspberrypi.org/products/poe-hat/

I enabled the I2C bus via the raspi config menu

Edit: I’m also getting a lot of these messages:

[ 423.196749] i2c-bcm2835 fe804000.i2c: i2c transfer timed out


@mik_il - We procured one of those POE HATs and we are going to take a look in house.

The POE HAT worked for me. I did some experimenting and removed GPIO2-GPIO3, and GPIO4 from the HAT and it still worked. If there was a conflict with the Zymkey, I would expect it would’ve been on those pins.
If you’re seeing a lot of the “i2c: transfer timed out”, double-check the connection of GPIO4 to the Zymkey. Another indicator would be the blue LED. If it flashes rapidly, then 8 slower flashes, it’s having communication problems most likely via GPIO4.

Thank you for investigating the issue so thoroughly. I will double check the connections, I suspect it’s the pin diameter of the extended headers I’m using to allow the GPIO pins to be long enough to pass through the hat and to the zymkey - I’d just expected it wouldn’t work at all but perhaps it’s intermittent…