Kali Latest Build


does anybody know if the latest build of kali is supported on a raspberry pi 4?

i have had it working on version 2020.b and found a previous post however I am unable to get the Zymbit installed on the latest version.

Hey Jon,

I had a chance to briefly take a look at this.

Kali 2022.3 worked and binded with our zymbit products following the same solution that was found here: Support for Kali Linux 2020.2b

Encrypting the sd card did not work for me. I found the error occurs due to a complaint on how the zymbit hook script is set up in the initramfs process. There may be something kali linux specifically looks for in the initramfs.

If you want to take a look at it yourself our encryption scripts are free to use and modify. Our encryption script can be downloaded via:

curl -G https://s3.amazonaws.com/zk-sw-repo/mk_encr_sd_rfs.sh --output mk_encr_sd_rfs.sh

You may also use this as reference from kali’s site to point you in the right direction: Raspberry Pi - Full Disk Encryption | Kali Linux Documentation

Thanks for your patience,

Thanks for the reply,

I don’t know if the script has changed but when i use the bind script now it doesn’t work but I had an old copy I downloaded a while back and that works with no issues.

I’ll give what you said a go and see if I can look to get it working again. Thanks for the direction if I need further support, I will reach out again.

@jon - the installation script has changed since I wrote those notes back when but the same instructions still work (I just ran through an installation). One difference would be the line number to set the distro to focal. This might be a more clear way to do it:


distro=`lsb_release -c | cut -f2 -d$'\t'`



It should be line 72, but just search for that line.


1 Like

Thanks bob,

I will try that one tomorrow when i am back with the kit. Did you also manage to get it to encrypt working using the second script? Or did you just bind the zymbit to kali?

I am struggling a bit trying to find the initramfs that eric recommended that may be the issue.

@jon - The encryption failed for me also. The initramfs output is called initrd.img. The problem is that it does not get created, which is why you don’t see it.

Kali Docs:
mkinitramfs -o /boot/initramfs.gz 5.15.44-Re4son-v8l+

mk_encr_sd_rfs.sh script:
update-initramfs -v -c -k uname -r -b /mnt/tmpboot

Maybe that’s the reason it doesn’t work?

Hey @Johnny and @jon ,

I went through this exact step. When you normally do the encryption script, kali bombs out on the script at the command update-initramfs and you’re left with no initrd.img.

When I went through that update-initramfs command stand-alone I saw an error that complained about the Zymbit hooks in the initramfs. This will give you an initrd.img, but it doesn’t work.

I’m assuming there is additional libraries or dependencies needed in initramfs for kali. For instance, kali’s site about disk encryption brings in additional dependencies like dmcrypt in the initramfs. I’m not sure if it’s needed, but that’s one difference.

I think I’ve got a one-line fix for the encryption script to work with Kali 2022.3. For some reason, the update_initramfs process wants a link to /boot that it didn’t need before.

Save the encryption script locally

curl -G https://s3.amazonaws.com/zk-sw-repo/mk_encr_sd_rfs.sh > mk_encr_sd_rfs.sh

Add a link after line 224.
Change from:

# Make the initramfs
echo -n "Building initramfs..."
rm /mnt/tmpboot/initrd.img-`uname -r` 2>/dev/null
update-initramfs -v -c -k `uname -r` -b /mnt/tmpboot/



# Make the initramfs
ln -s /mnt/tmpboot/* /boot/      # <- ADD THIS LINE
echo -n "Building initramfs..."
rm /mnt/tmpboot/initrd.img-`uname -r` 2>/dev/null
update-initramfs -v -c -k `uname -r` -b /mnt/tmpboot/

Reminder: Be sure you don’t have a file named original_zk_root.tgz on your USB stick or the script will use that as the source for your root filesystem files.

sudo mount /dev/sda1 /mnt
sudo rm /mnt/original_zk_root.tgz
sudo umount /mnt

Make the script executable, sudo su, and run the script.

chmod +x mk_encr_sd_rfs.sh
sudo su
1 Like

Hi @Bob_of_Zymbit i can confirm this has worked for me. thanks for all your help.