LED Blinking Issue

I have placed the zymbit module on the raspberry pi 4 and installed the packages as your documentation said. However my RPi 4 was restarted once during the package installation then it backed in normal without knowing whether the installation has been completed or not. in order to verify that I ran the command ‘systemctl status zkifc’ and the result was shown as active.
As the documentation says the LED should blink once for every 3 seconds but mine is blinking for around every 1 second for a instance and then again starts to blink rapidly within a second for about 3 seconds.
I am new to this product and hope someone with me on this.

@Asghida - The first part of the process is what is expected during the installation. The PI will reboot once and then the blue LED should begin to flash once every 3 seconds.

The most common issue we see is with power. The PI4 needs a good power supply that provides at least 2.5 or 3 amps. The official power supplies from raspberrypi.org or canakit are good choices. The next thing I would ask is to make sure you did an apt-get update; apt-get upgrade to get the latest OS updates, and of course that you enabled your i2c bus.

Which operating system are you running on your PI4?


1 Like

Hi @Bob_of_Zymbit,
I have enabled the i2C bus first. Actually, I cannot remember whether I did the update and upgrade processes but however since the reply came I have already tried the encryption of the root file system on the SD card and it is still processing without any issue. So I think the initial installation was OK but the LED is blinking fast - I think it is occurring because of the low power.
Im using Raspbian GNU/Linux 10 (buster).
Thank you for your prompt response.

The encryption process will do two reboots. The blue LED will flash rapidly during the process. Once the process completes, it will return to flashing once every 3 seconds. After the first reboot, you can monitor progress with:

journalctl -fu cfg_SD_crfs

It takes a little time and requires some patience!

1 Like

Yeah, I think the encryption was completed. However, the screen shows only a dash(-) mark on the top of the left corner - nothing else. The LED is still blinking fast. I will update you once the process is completed. :innocent:
thank you @Bob_of_Zymbit

Hi! after few days,
After running successful installation the pi was rebooted and I also ran the following commands to check out the connection.
python /usr/local/share/zymkey/examples/zk_app_utils_test.py
python /usr/local/share/zymkey/examples/zk_crypto_test.py

The second command was run successfully but not the first one. But after some hours from a shutdown, both commands were not working but the status was active as shown below.

systemctl status zkifc.service
● zkifc.service - Zymkey Interface Connector
Loaded: loaded (/etc/systemd/system/zkifc.service; enabled; vendor preset: enabled)
Active: active (running) since Tue 2021-03-09 10:45:27 +0530; 51min ago
Process: 2899 ExecStartPre=/bin/bash -c mkdir -p /run/zkstatus && chown -R zymbit.zymbit /run/zkstatus (code=exited, status=0/SUCCESS)
Process: 2901 ExecStartPre=/bin/sleep 0.5 (code=exited, status=0/SUCCESS)
Main PID: 2908 (zkifc)
Tasks: 3 (limit: 4915)
CGroup: /system.slice/zkifc.service
└─2908 /usr/bin/zkifc -s /var/lib/zymbit/

Mar 09 10:45:26 pivpn systemd[1]: Starting Zymkey Interface Connector…
Mar 09 10:45:27 pivpn systemd[1]: Started Zymkey Interface Connector.

Please need a prompt guidance.
Thank you!

Hi All,
its glad to inform you that I have successfully encrypted the root file system using the existing SD card(option 1). I think Sooooo…
Because as you said earlier there was two reboots while the encryption process and now the LED is blinking once for every three seconds.
Need to know whether there is a proper way to know about the success of the root file encryption as I have converted the existing SD card to LUKS.