Verifying Zymkey Signatures against Public Key on AWS and other Devices

For the most recent documentation on verifying signatures, see Zymbit’s Documentation Site.

Instead of AWS, can I use another RaspberryPi 3 to decrypt the stored data. I am using Ethereum and IPFS for distributed storage.

I just bought Zymkey. I tried to publish data to the cloud. But I got an error when signing the certificate. I tried also the code in the first part of this discussion and got the same error.

The error is:

Traceback (most recent call last):
File “”, line 6, in
payload_sig = zymkey.client.sign(encrypted_payload)
File “/usr/local/lib/python2.7/dist-packages/zymkey/”, line 325, in sign
AttributeError: ‘bytearray’ object has no attribute ‘encode’

Any solution for that error?

It looks like the code snippet is incorrect. Things should work for you if you change line 6 from
data = bytearray('hello world!')
data = 'hello world!'

Hi, I had the same issue and when I use: data = ‘hello world!’ I get the following error:
Traceback (most recent call last):

File “/home/admin/”, line 5, in
encrypted_payload = zymkey.client.lock(data)
File “/usr/local/lib/python3.7/dist-packages/zymkey/”, line 230, in lock
raise AssertionError(‘bad return code %d’ % ret)
AssertionError: bad return code -2