Zymkey production mode failed


I have done the following actions:

  1. Successfully encrypted root file system using Zymkey’s guide. My app is a Node JS server running on a Raspberry Pi.
  2. Prepared perimeter detect as described in tutorial:
python3 -c "import zymkey;
for ch in (0, 1):
    zymkey.client.set_perimeter_event_actions(ch, action_notify=False, action_self_destruct=False)
  1. Cut the lock tab as described.
  2. Powered up the device, but it did not boot.

What did I do wrong? Thank you!

Subject: Raspberry Pi.

@chirikov - Can you tell me which OS (e.g. raspberry OS 64 or 32 bit) and PI? Are you getting any messages on the console? I’ll take a quick look.


Hi Bob! I’m using Raspberry Pi OS with desktop 32 bit. This was RPi model 3 (3B most probably).

I can’t comment on the console, I didn’t take pictures.

I plan to try again, this time with RPi 4. But before I try I’d like to know what should I do differently.

To be clear: my app does not use any Zymkey API to interact with it.

@Bob_of_Zymbit , do you have any updates?

@chirikov - I ran through the steps just to make sure it works and it works fine for me. I used a Pi4 because that’s what I had handy.

It would be good if you still had the original setup to see how far in the boot process it made it. You’d have to have the same Pi, same SD card, and same Zymkey.

If not, I don’t see anything wrong in the steps.

1 Like

Hi Bob,

I tried again with RPi 4 and it worked well. Thank you!