Compatibility with other SoC


With the raspberry cm4 shortage, I tried to find an alternative. The Pine64 SoQuartz64 is pin compatible with the CM4, so it can be installed on any CM4 main board. It is based on an arm64 architecture, and I succesfully installed debian buster on it with kernel 5.16.0 : SOQUARTZ 4GB COMPUTE MODULE W - PINE STORE

Now I would like to use the Zymkey 4i to encrypt rootfs, but it’s not fully supported. I can install packages, and i2cdetects address 30, but no zymkey is found.

So I am here to ask you if there is a chance to port zk packages to this SoC (at minimum the package needs to handle /dev/ic2-6, and change the access to GPIOs).

@gdumee As an aside, may help in locating PIs.

As far as using the Pine64, we have not verified our products on that platform. If needed, you can specify a different WAKE_ON pin as well as the i2c bus number to check.

Make a file in /var/lib/zymbit/ named zkenv.conf and add the following entries:

ZK_GPIO_WAKE_PIN=<platform pin number>

where <platform pin number> is the one on that platform that corresponds to the default GPIO4 on the RPi.

The device scan will go through all the i2c busses which can take a long time. You can specify the specific bus you are on. For instance, for i2c=6 add,

restricts the zymkey scan only to bus 6 (/dev/i2c-6)

Hope that helps,

Hi @Bob_of_Zymbit
Thank you for your help. I successfully used my Zymkey on a SoQuartz64 to crypt rootfs in eMMC. My main problem was the kernel that had no /sys/class/gpio support, and no crypt modules. I recompiled it (a lot !) and, with the config file to change wakeup GPIO, I finally succeedded :sweat_smile:

1 Like

Hi Gdumee,

I’m facing the same issue with an ODROID N2+ right now. I’ve recompiled my kernel with CONFIG_GPIO_SYSFS=y, but still not seeing the /sys/class/gpio files. How did you do it?


Hi @amplitude
If you can use “make menuconfig”, and search for CONFIG_GPIO_SYSFS, you can see dependencies with other configs : the CONFIG_GPIO_SYSFS depends on CONFIG_EXPERT=y (i’m using a 5.17 kernel)