Elastos Blockchain Project


#1

Hi Phil,

Nice talking to you on the phone, sorry about the bad cell signal.

Well, I just wrote something on my github to explain what I am trying to do with Zymbit and RPI. Check this out https://github.com/kevingzhang/TrustedComputing_POC

Very brief, not sure if easy to understand or not.

BTW, i am the CTO of Elastos.org (Silicon Valley). Elastos is a blockchain project. However, what I am working on is not part of existing Elastos project, it could be the future of Elastos if everything goes right.

If the Trusted Computing can be combined with blockchain, there would be thousands of thousands of mining machine equipped with Zymbit TPM running to min cryptocurrency at the mean time provide trust computing services. This is my goal.

If you are interest in this idea too, I would like to setup a call with you or any others from Zymbit. I live in Silicon Valley, I know your guys in Santa Babara, CA. Not too far.

BTW, I am waiting for Python dev doc.

Thank you very much.

Kevin Z


#2

@kevinzhang
Thanks or sharing details of your Elastos project and use of zymbit security module. We would like to learn more, and will send an email invite.

Updated python documents are available here >
https://s3.amazonaws.com/zk-sw-repo/zk_app_utils.py.pdf

(I have moved your original post to this new thread “Elastos Blockchain Project” - making it easier for others to find/participate)


Random number generator in Zymkey - Clarification Please!
#3

Hi Phil.

Try to run the zk_app_utils_test.py but got the following error.

I tried in Python2.7, 3.5, 3.7,. the same error.

Traceback (most recent call last):

File “test.py”, line 1, in

import zymkey

File “/home/pi/Documents/testcode/zymkey/init.py”, line 3, in

from .module import Zymkey

File “/home/pi/Documents/testcode/zymkey/module.py”, line 56, in

class Zymkey(object):

File “/home/pi/Documents/testcode/zymkey/module.py”, line 578, in Zymkey

_zkSetGMTTime = zkalib.zkSetGMTTime

File “/usr/lib/python3.5/ctypes/init.py”, line 360, in getattr

func = self.__getitem__(name)

File “/usr/lib/python3.5/ctypes/init.py”, line 365, in getitem

func = self._FuncPtr((name_or_ordinal, self))

AttributeError: /usr/local/lib/libzk_app_utils.so: undefined symbol: zkSetGMTTime


#4

Hi Kevin

Can you tell us how you installed the Zymkey packages.

Thanks


#5

I installed as the Getting Start Guide described.


#6

Kevin, this isn’t making sense to us - somehow your pulling in some old modules. We have opened up a new support ticket and will need to take a closer look at what’s going on. We’ll update you when we know more.


#7

OK, is it possible to create a docker image that I can run inside a docker container? Usually this can fix all kind of configuration problem


#8

We are working on understanding/resolving the issue you describe.
Yes we have other customers who run within docker containers - but that won’t obviously resolve the issues you are experiencing.


#9

OK, If you cannot reproduce the issue, I could probably create a docker image that can reproduce this problem. You can download the same image and run in your own docker container, so you can easily reproduce it.


#10

Have not heard from you for a while. I have got some progress on the trusted computing blockchain project. I would like to talk to one of your Biz Dev person.