Zymbit4 no blink

I have done the luks crypt and everything was working ok. Today I power up the Pi and it would not boot as the boot key was not accessible by the Pi. The Zymbit led is not blinking at all. Also, the tab has not been cut yet.

What could be wrong here. Is the Zymbit Key dead?

Hello Albert,

Can you tell me which PI, OS, and capture the last messages you see on the console? Is this a new setup or has it been working fine for a long time and then stopped working after the power up?



It was working for fine for a few days with powering up and down. Then on the last time I powered it up, it would not boot and the Zymbit with no LED blink. The PI itself is working as I have reinstall the OS and Luks Crypt with a new Zymbit.

Putting the Zymbit on a new Pi also did not result in any blinking LED.

  1. Raspberry Pi 3B+
  2. Ubuntu 20.04 with all patches

Is there any other information that is needed, please let me know? Thank you.

I have a another brand new Zymbit that is dead again. No blinking LED and the Raspberry Pi 3B+ does not boot. The Zymbit is in production mode with battery install.

  1. Prepare the Zymbit
  2. Encrypt the Zymbit for Secure Boot.
  3. Shutdown
  4. Boot up PI again next day (Zymbit is dead).

Hello Albert, Most likely ubuntu has done an upgrade and tried to build a new initramfs. You should turn off the unattended-upgrades once you have encrypted your root partition.

systemctl stop unattended-upgrades
systemctl disable unattended-upgrades

The auto update has been stopped just after the first boot before the Zymbit was installed. Now I have 2 Zymbit that does not blink even if I install in on a new PI. Is there any to check the status of the Zymbit or revive it? I am 100% sure that it was never set to production mode.


Same issue with me. One device dead no blink after boot complete. It rapidly boots when power up but as Zymkey service start Led Blinking gone.

I have tried to probe the 12C, nothing, non of the test sample code runs. I know the Pi is working as I put in a new Zymbit and the sample code works. So it look from the outside. like it has execute the kill switch. The problem is that I have not activate any of the perimeter sensing code and the tab is still intact.

Same here… New device worked but old device with tab intact led blink only boot time then nothing. May be device is bricked.

At least you unit blinked at boot time. I have two units that does not blink at all. Even plugging it in on a new PI.

I had impression this device is good for industrial use but not good. Even no support from zymbit on my last two queries.

I also have few queries where device get bricked after 2-3 month usage posted here.

No Reply from support team yet.

I am thinking to move to another options. i.e. Encrypt partition and decrypt automatically using password from cloud server.

@Albert @nareshn2003 I’d like to address your two issues separately. You seem to have two different situations but the end result is a ZYMKEY that is not blinking. One thing as always is to make sure you have a good power source, not a phone charger. The ZYMKEY will put itself in sleep mode if it detects inadequate power so we need to eliminate that first. I will contact each of you directly via support to get more information on the history of your particular ZYMKEYs.